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CHAPTER – 1 

EVOLUTION OF COMPUTERS 
 

Devices Used Before Computers 

 

Before modern computers were invented, people used various devices and 
machines to help with calculaƟons and data processing. Some of the most 
notable devices are: 

 1. Abacus (c. 2400 BC) 

The Abacus is one of the oldest known calculaƟng tools. It consists of a frame 
with rods or wires that hold beads. Each bead represents a unit of value (ones, 
tens, hundreds, etc.). The user moves the beads to perform basic arithmeƟc 
operaƟons like addiƟon, subtracƟon, mulƟplicaƟon, and division. The abacus 
was widely used in ancient civilizaƟons like China, Greece, and Egypt. 

 

 2. Pascaline (1642) 

The Pascaline, invented by Blaise Pascal, was one of the first mechanical 
calculators. It could perform addiƟon and subtracƟon by turning a set of dials. 
The device used gears and wheels to represent numbers, and users could add 



or subtract numbers by turning the dials. It was a major advancement in 
mechanical calculaƟon devices. 

 

  

3. Leibniz’s Step Reckoner (1672) 

Goƪried Wilhelm Leibniz invented the Step Reckoner, a machine that could 
perform all four basic arithmeƟc operaƟons: addiƟon, subtracƟon, 
mulƟplicaƟon, and division. The machine was more advanced than the 
Pascaline, using a stepped drum mechanism to carry out calculaƟons. 

 4. AnalyƟcal Engine (1837) 

The AnalyƟcal Engine was designed by Charles Babbage and is considered the 
first concept of a general-purpose computer. It was a mechanical device that 
could perform any arithmeƟc calculaƟon, store numbers, and even handle 
condiƟonal instrucƟons. Although it was never fully built during Babbage’s 
Ɵme, the design included key features such as a control unit, an arithmeƟc 
logic unit, memory, and input/output devices—many of which are essenƟal to 

modern computers. 



 

 5. Difference Engine (1822) 

Also designed by Charles Babbage, the Difference Engine was a mechanical 
calculator designed to compute mathemaƟcal tables. It could only perform 
specific calculaƟons, like polynomial funcƟons, but it was an important step 
toward the development of more complex compuƟng machines. 

 

These devices, though not as advanced as modern computers, laid the 

foundaƟon for compuƟng technology and were instrumental in the 
development of later computaƟonal machines.  

 

IntroducƟon to the EvoluƟon of Computers 

 

The evoluƟon of computers is a fascinaƟng journey that spans over centuries. It 
began with simple mechanical devices and has progressed to today’s highly 
advanced and intelligent systems. In this lesson, we will explore the major 
generaƟons of computers, key milestones, and famous invenƟons that shaped 
the world of compuƟng. Understanding this history helps us appreciate the 
remarkable progress made in technology. 



 

 

GeneraƟons of Computers 

 

1. First GeneraƟon (1940-1956) 

 • Technology: The first electronic computers used vacuum tubes, 
which were large, unreliable, and generated excessive heat. 

 • Notable Computers: 

 • ENIAC (1946): The Electronic Numerical Integrator and Computer 
was the first general-purpose electronic computer. 

 • UNIVAC 1 (1951): The Universal AutomaƟc Computer 1 was the 
first commercially available computer. 

 

2. Second GeneraƟon (1956-1963) 

 • Technology: Transistors replaced vacuum tubes, making computers 
smaller, faster, and more reliable. 

 • Notable Computers: 

 • IBM 7090 (1959): A popular second-generaƟon computer used for 
scienƟfic calculaƟons. 

 

3. Third GeneraƟon (1964-1971) 



 • Technology: Integrated Circuits (ICs) combined mulƟple transistors 
on a single chip of silicon, making computers even smaller and more efficient. 

 • Notable Computers: 

 • IBM 370 (1970): A popular third-generaƟon computer used for 
business applicaƟons. 

 

4. Fourth GeneraƟon (1971-1980) 

 • Technology: Microprocessors combined all the components of a 
computer’s central processing unit (CPU) onto a single chip of silicon. 

 • Notable Computers: 

 • Apple I (1976): One of the first personal computers, designed and 
hand-built by Steve Wozniak. 

 

5. FiŌh GeneraƟon (1980-present) 

 • Technology: The fiŌh generaƟon of computers focuses on arƟficial 
intelligence (AI), parallel processing, and the Internet. 

 • Notable Computers: 

 • IBM PC (1981): A widely adopted personal computer that set 
industry standards. 

 

Key Milestones in Computer History 

 

1. Charles Babbage’s AnalyƟcal Engine (1837) 

 • Mechanical Computer: Charles Babbage proposed the idea of a 
mechanical computer called the AnalyƟcal Engine. 

 • Input/Output Devices: The AnalyƟcal Engine had input/output 
devices, such as cards and printers. 

 

2. Punch Cards (1890s) 



 • Data Input: Punch cards were used for data input and storage in 
early computers. 

 • Herman Hollerith: Developed the first mechanical tabulator using 
punch cards. 

 

3. Electronic Computers (1940s) 

 • ENIAC: The first general-purpose electronic computer. 

 • John Mauchly and J. Presper Eckert: The designers and builders of 
the ENIAC. 

 

4. Personal Computers (1970s) 

 • Apple I: One of the first personal computers. 

 • IBM PC: A widely adopted personal computer that set industry 
standards. 

 

5. Internet and World Wide Web (1990s) 

 • Internet: Became widely available, revoluƟonizing communicaƟon 
and informaƟon sharing. 

 • World Wide Web: Invented by Tim Berners-Lee, making it easy to 
access and share informaƟon using web browsers and hyperlinks. 

  



 

EXERCISE – chapter 1 

1. Fill in the Blanks: 

a) The Abacus is one of the oldest calculaƟng tools used by ancient civilizaƟons 
like China, Greece, and Egypt. 

b) The Pascaline was invented by Blaise Pascal and could perform addiƟon and 
subtracƟon using gears and dials. 

c) Charles Babbage is considered the father of compuƟng, and his AnalyƟcal 
Engine is the first concept of a general-purpose computer. 

d) The AnalyƟcal Engine was designed in the year 1837. 

e) The first general-purpose electronic computer was called ENIAC. 

 

2. True or False: 

 

a) The AnalyƟcal Engine was fully built and used during Charles Babbage’s Ɵme. 
(False) 

b) The Difference Engine was a mechanical calculator that could only compute 
polynomial funcƟons. (True) 

c) The first generaƟon of computers used transistors. (False) 

d) The IBM PC was released in the fiŌh generaƟon of computers. (True) 

e) The Internet and World Wide Web became widely available in the 1990s. 
(True) 

 

3. Match the Following: 

 

Column A Column B 

1. Abacus A. First general-purpose computer 



2. Pascaline B. Invented by Charles Babbage 

3. ENIAC C. Used for basic arithmeƟc operaƟons 

4. AnalyƟcal Engine D. Invented by Blaise Pascal 

5. Punch Cards E. Used for input and storage in early computers 

 

4. MulƟple Choice QuesƟons: 

 

a) Which device was invented by Blaise Pascal for performing arithmeƟc 
operaƟons? 

i. Abacus 

ii. Pascaline 

iii. AnalyƟcal Engine 

iv. ENIAC 

Answer: ii. Pascaline 

 

b) Who is known as the father of compuƟng? 

i. John Mauchly 

ii. Charles Babbage 

iii. Blaise Pascal 

iv. Steve Wozniak 

Answer: ii. Charles Babbage 

 

c) Which generaƟon of computers introduced microprocessors? 

i. First GeneraƟon 

ii. Second GeneraƟon 

iii. Third GeneraƟon 

iv. Fourth GeneraƟon 



Answer: iv. Fourth GeneraƟon 

 

d) The internet and World Wide Web became widely accessible in which 
decade? 

i. 1960s 

ii. 1980s 

iii. 1990s 

iv. 2000s 

Answer: iii. 1990s 

 

4. Short Answer QuesƟons 

 1. What is a microprocessor, and how does it work in modern 
computers? 

 2. Explain the role of punch cards in early computer systems. 

 3. What is the significance of the IBM 7090 in the history of 
computers? 

 4. Describe how transistors helped improve computers compared to 
the first generaƟon. 

 5. What was the contribuƟon of Charles Babbage to the history of 
computers? 

 

5. Long Answer QuesƟons 

 1. Explain the impact of the invenƟon of the transistor on the 
evoluƟon of computers. Discuss how it led to smaller, faster, and more reliable 
computers. 

 2. Describe the key milestones in computer history from the first 
generaƟon to the fiŌh generaƟon. Explain how each generaƟon improved upon 
the last. 



 3. **Write about the development and importance of the World 
Wide Web. Discuss how it has transformed the way people access and share 
informaƟon. 

 4. **Discuss the evoluƟon of personal computers from the Apple I to 
the IBM PC. What changes did these computers bring to the world? 

 5. Explain how the invenƟon of the ENIAC and UNIVAC 1 
revoluƟonized compuƟng. What were the challenges of the first-generaƟon 
computers, and how were they addressed in the second generaƟon? 

  



 

CHAPTER – 2 

MANAGING FILES AND FOLDERS IN UBUNTU 

 

IntroducƟon 

 

Ubuntu is a popular Linux-based operaƟng system. It’s user-friendly and widely 
used around the world. The desktop environment in Ubuntu provides a 
graphical interface that allows users to interact with files, folders, and 
applicaƟons easily. Understanding how to use the Ubuntu desktop and how to 
manage files and folders is essenƟal for organizing work and staying producƟve. 

 

In this lesson, we will learn about the Ubuntu desktop and how to manage files 
and folders effecƟvely. 

 

1. Understanding the Desktop of Ubuntu 

 

 

The desktop in Ubuntu is the main screen where you interact with the 
computer. It contains several important elements that help you work efficiently. 



 

Components of the Ubuntu Desktop 

 

 

 1. Top Bar: 

 • The top bar is found at the top of your screen. It displays 
important informaƟon such as the current Ɵme, baƩery status, network 
connecƟon, and system noƟficaƟons. You can also access the System Seƫngs, 
Sound, User Profile, and ApplicaƟon Menus from here. 

 2. AcƟviƟes Overview: 

 • By clicking the AcƟviƟes buƩon (or pressing the Super key, which is 
the key with the Ubuntu logo), you can open the AcƟviƟes Overview. This 
shows you all the open applicaƟons, your workspace, and a search bar to find 
applicaƟons, files, or seƫngs. 

 3. Dock: 

 • The dock is a row of icons found on the leŌ side of your screen. 
These are quick access icons for your favorite or frequently used applicaƟons 
(e.g., Firefox, Files, LibreOffice Writer). You can add or remove items from the 
dock by dragging them. 

 4. Wallpaper: 



 • The wallpaper is the background image on your desktop. You can 
customize it by right-clicking on the desktop and selecƟng Change Background. 

 5. Icons: 

 • The desktop may also have icons for files, folders, and 
applicaƟons. These can be organized and moved around as per your 
preferences. 

 

2. Managing Files and Folders in Ubuntu 

 

In Ubuntu, managing files and folders is done through the File Manager, known 
as NauƟlus. It allows you to organize and keep track of your files in an easy and 
accessible way. 

 

 

Opening the File Manager 

 1. To open NauƟlus, click the Files icon from the dock or search for 
Files in the AcƟviƟes overview. 

 2. The File Manager window opens, showing your home directory 
where you can access your documents, pictures, music, and other files. 

 

CreaƟng and Organizing Files and Folders 

 

1. CreaƟng a Folder 



 

To keep your files organized, you may need to create new folders. Follow these 
steps: 

 1. Open the File Manager. 

 2. Right-click on an empty area of your desktop or inside a folder. 

 3. Select “New Folder” from the context menu. 

 4. Type the name for your folder (e.g., “School Projects”) and press 
Enter. 

 

2. CreaƟng a File 

 

To create a new file (e.g., a text document): 

 1. Right-click on an empty space in a folder. 

 2. Select “New Document”, and then “Empty Document”. 

 3. Rename the document (e.g., “Math Homework”). 

 4. Double-click to open and edit the file. 

 

3. Moving Files and Folders 

 

You can move files and folders from one locaƟon to another: 

 1. Click and hold the file or folder you want to move. 

 2. Drag it to the new locaƟon. 

 3. Release the file or folder to drop it into the new folder. 

 

AlternaƟvely: 

 1. Right-click on the file or folder. 

 2. Select “Cut”. 



 3. Navigate to the desƟnaƟon folder, right-click, and select “Paste”. 

 

4. Renaming Files and Folders 

 

To rename a file or folder: 

 1. Right-click on the file or folder. 

 2. Select “Rename”. 

 3. Type the new name and press Enter. 

 

5. DeleƟng Files and Folders 

 

If you want to delete a file or folder: 

 1. Right-click on the file or folder. 

 2. Select “Move to Trash”. 

 3. To permanently delete it, go to the Trash and empty it. 

 

6. Searching for Files 

 

To search for a file in Ubuntu: 

 1. Open NauƟlus (File Manager). 

 2. In the top-right corner, there is a search bar. 

 3. Type the name of the file or folder you are looking for, and the 
results will appear instantly. 

 

3. Using the Terminal for File Management (OpƟonal) 

 



While the graphical interface is easier for beginners, advanced users someƟmes 
prefer the Terminal (a command-line interface) for managing files. Commands 
like cd, cp, mv, and rm are used for navigaƟng directories and performing 
acƟons on files. 

 

Important Commands: 

 • ls: Lists files and directories in the current folder. 

 • cd: Changes the directory you are working in. 

 • cp: Copies files or folders. 

 • mv: Moves files or folders. 

 • rm: Deletes files or folders. 

 

 

 

 

 

 

 

 

 

  



Exercises Chapter 2 
 

1. Fill in the Blanks (5) 

 1. The area on the screen where you interact with the operaƟng 
system is called the __________. 

 2. The __________ is a row of icons on the leŌ side of the screen 
that gives quick access to your favourite applicaƟons. 

 3. To create a new folder in Ubuntu, you need to ________ on an 
empty area of the screen or inside a folder. 

 4. The files you delete are moved to the __________ before being 
permanently removed. 

 5. The default file manager in Ubuntu is called __________. 

 

2. MulƟple Choice QuesƟons (MCQs) (5) 

 1. Which part of the Ubuntu desktop shows the Ɵme and system 
noƟficaƟons? 

 • a) Top Bar 

 • b) Dock 

 • c) Wallpaper 

 • d) AcƟviƟes Overview 

Answer: a) Top Bar 

 2. What is the shortcut key to open the AcƟviƟes Overview in 
Ubuntu? 

 • a) Ctrl + A 

 • b) Super + E 

 • c) Super key (Windows key) 

 • d) Ctrl + D 

Answer: c) Super key (Windows key) 



  

3. Which of the following is used to access files and folders in Ubuntu? 

 • a) System Seƫngs 

 • b) Terminal 

 • c) File Manager (NauƟlus) 

 • d) Firefox 

Answer: c) File Manager (NauƟlus) 

 4. To delete a file or folder in Ubuntu, you can right-click and select: 

 • a) “Cut” 

 • b) “Move to Trash” 

 • c) “Rename” 

 • d) “Open” 

Answer: b) “Move to Trash” 

 5. Where can you change the wallpaper in Ubuntu? 

 • a) File Manager 

 • b) Top Bar 

 • c) AcƟviƟes Overview 

 • d) Right-click on the Desktop 

Answer: d) Right-click on the Desktop 

 

3. True or False (5) 

 1. True or False: The Dock in Ubuntu provides quick access to the 
applicaƟons you use most oŌen. 

 • Answer: True 

 2. True or False: You cannot search for files in Ubuntu’s File Manager. 

 • Answer: False 



 3. True or False: Files in Ubuntu are deleted permanently without 
going to the Trash. 

 • Answer: False 

 4. True or False: The AcƟviƟes buƩon helps you find and open 
applicaƟons and files in Ubuntu. 

 • Answer: True 

 5. True or False: To open the File Manager, you must always use the 
Terminal. 

 • Answer: False 

 

 

4. Match the Columns (5) 

 

Column A                                                    Column B 

1. File Manager (NauƟlus).      a) Used for quick access to frequently used 
applicaƟons 

2. Dock                                   b) Used to find and manage files and folders 

3. Trash                                    c) Contains deleted files before permanent 
removal 

4. Top Bar.                             d) Displays the Ɵme, network, and system 
noƟficaƟons 

5. Wallpaper                        e) The background image of your desktop 

 

Answer: 

 1. b – File Manager (NauƟlus): Used to find and manage files and 
folders. 

 2. a – Dock: Used for quick access to frequently used applicaƟons. 

 3. c – Trash: Contains deleted files before permanent removal. 



 4. d – Top Bar: Displays the Ɵme, network, and system noƟficaƟons. 

5. Short Answer QuesƟons (5) 

 1. What is the funcƟon of the Dock in Ubuntu? 

 2. How do you create a new folder in Ubuntu? 

 3. What happens when you delete a file in Ubuntu? Where does it go 
before being permanently removed? 

 4. How can you change the wallpaper in Ubuntu? 

 5. What is the Top Bar in Ubuntu used for? 

 

 

6. Long Answer QuesƟons (5) 

 1. Explain the components of the Ubuntu desktop. Describe the 
purpose of the Top Bar, Dock, Wallpaper, and AcƟviƟes Overview in detail. 

 2. How do you manage files and folders in Ubuntu using the File 
Manager (NauƟlus)? Include steps for creaƟng, renaming, moving, and deleƟng 
files and folders. 

 3. What is the purpose of the “Trash” in Ubuntu? Describe how files 
are moved to the Trash and how you can permanently delete them. 

 4. Discuss how to search for files in Ubuntu. What are the different 
ways you can search for a specific file or folder in the File Manager? 

 5. What are the different ways you can customize the Ubuntu 
desktop? Discuss how you can change the wallpaper, adjust the dock, and 
personalize other seƫngs to make your desktop more user-friendly. 

 

 

  



 

CHAPTER 3 

Formaƫng in Libre Office Writer 
 

IntroducƟon to LibreOffice Writer 

LibreOffice Writer is a word processing soŌware that allows you to create, edit, 
and format documents such as leƩers, essays, reports, and more. It is similar to 
MicrosoŌ Word, but it is free and open-source. Formaƫng and inserƟng 
various elements into a document help to organize informaƟon and make it 
look more professional and visually appealing. 

 

In this lesson, we will learn how to use different formaƫng tools in LibreOffice 
Writer and how to insert various elements like pictures, tables, and lists into 
our documents. 

 

1. Basic Formaƫng in LibreOffice Writer 



 
 

 

Formaƫng text in LibreOffice Writer makes your document easy to read and 
visually aƩracƟve. Here are some common formaƫng opƟons: 

 

Changing the Font Style, Size, and Color 

 1. Font Style: Choose a font style to make your text look different 
(e.g., Arial, Times New Roman, Calibri). 

 • To change the font, select the text and click on the font dropdown 
in the toolbar. 

 2. Font Size: You can adjust the size of your text to make it larger or 
smaller. 

 • Select the text, and from the toolbar, choose the desired font size. 

 3. Font Color: To change the color of the text: 

 • Select the text and click on the Font Color buƩon in the toolbar. 

 • Choose the color from the paleƩe that appears. 

 

Aligning Text 

 

You can align text in different ways: 

 • LeŌ Alignment: Aligns text to the leŌ side of the page. 

 • Center Alignment: Centers the text on the page. 

 • Right Alignment: Aligns text to the right side of the page. 

 • JusƟfy: Makes the text evenly spaced between the leŌ and right 
margins. 

 

To align text: 



 1. Select the text. 

 2. Click on the Align buƩons in the toolbar (leŌ, center, right, or 
jusƟfy). 

 

Bold, Italic, and Underline 

 

You can make text stand out by using bold, italics, or underlining: 

 • Bold: Makes text thicker and darker. 

 • Italic: Slants the text to the right. 

 • Underline: Draws a line under the text. 

 

To apply these styles: 

 1. Select the text. 

 2. Click on the Bold, Italic, or Underline buƩons in the toolbar, or use 
the keyboard shortcuts: 

 • Ctrl + B for bold 

 • Ctrl + I for italics 

 • Ctrl + U for underline 

 

Changing the Paragraph Spacing and IndentaƟon 

 1. Paragraph Spacing: You can change the space between lines in a 
paragraph or between different paragraphs: 

 • Select the paragraph. 

 • Right-click and choose Paragraph. 

 • In the dialog box, adjust Line Spacing and Before/AŌer paragraph 
spacing. 

 2. IndentaƟon: You can indent the first line of a paragraph or the 
enƟre paragraph. 



 • To indent, click the Increase Indent or Decrease Indent buƩons in 
the toolbar. 

 

Bullet Points and Numbered Lists 

 

LibreOffice Writer allows you to create bulleted or numbered lists to organize 
informaƟon. 

 1. Bulleted List: For a list with bullet points. 

 • Select the text you want to convert into a list. 

 • Click on the Bullets buƩon in the toolbar. 

 2. Numbered List: For a list with numbers. 

 • Select the text you want to convert into a numbered list. 

 • Click on the Numbering buƩon in the toolbar. 

 

 



2. InserƟng Elements into a Document 

 
 

 

In addiƟon to formaƫng text, you can insert various objects into your 
document to enhance it. 

 

InserƟng Pictures 

To make your document more interesƟng, you can insert images from your 
computer or the internet. 

 1. Click where you want to insert the picture. 

 2. Go to the Insert menu and select Image. 

 3. Browse for the image on your computer and click Open to insert it 
into your document. 

 

You can resize or move the image by clicking on it and dragging the corners. 

 



InserƟng Tables 

A table is useful when you need to organize informaƟon in rows and columns. 

 1. Click where you want to insert the table. 

 2. Go to the Table menu and select Insert Table. 

 3. In the dialog box, specify the number of rows and columns. 

 4. Click OK, and the table will appear in your document. 

 

You can now enter data into the cells, resize the columns, and adjust the table 
formaƫng. 

 

InserƟng Page Breaks 

 

To start a new page in the middle of your document: 

 1. Place the cursor where you want the new page to begin. 

 2. Go to the Insert menu and select Manual Break. 

 3. Choose Page Break and click OK. 

 

InserƟng Hyperlinks 

 

To add a clickable link to a website or another secƟon of the document: 

 1. Select the text that you want to turn into a hyperlink. 

 2. Go to the Insert menu and select Hyperlink. 

 3. In the dialog box, enter the URL of the website or the address of 
another document. 

 4. Click Apply. 

 

3. Saving and PrinƟng the Document 



Saving Your Document 

 

To save your work: 

 1. Click on the File menu. 

 2. Select Save or Save As. 

 3. Choose the locaƟon where you want to save your document and 
give it a name. 

 4. Click Save. 

 

PrinƟng the Document 

 

To print your document: 

 1. Go to the File menu. 

 2. Select Print. 

 3. Choose your printer and print seƫngs, then click OK. 

 

Summary of Key Concepts 

 • Formaƫng text involves changing font style, size, color, alignment, 
and adding styles like bold, italics, and underline. 

 • You can insert images, tables, and hyperlinks into your document 
to make it more informaƟve. 

 • Using lists, paragraph spacing, and indentaƟon helps to organize 
your content. 

 • You can save and print documents from within LibreOffice Writer. 

 

 

  



Exercises Chapter 3 
 

Fill in the Blanks (5) 

 1. The buƩon used to make text bold in LibreOffice Writer is the 
__________ buƩon. 

 2. To insert a table into a document, you need to go to the 
__________ menu. 

 3. The buƩon used to change the alignment of text is the 
__________ buƩon. 

 4. You can change the color of text using the __________ buƩon on 
the toolbar. 

 5. To start a new page in the middle of a document, you use the 
__________ break. 

 

MulƟple Choice QuesƟons (MCQs) (5) 

 1. Which of the following is used to align text in LibreOffice Writer? 

 • a) Font Style 

 • b) Bullet Points 

 • c) Align BuƩons 

 • d) Hyperlink 

 • Answer: c) Align BuƩons 

 2. What is the default font style in LibreOffice Writer? 

 • a) Times New Roman 

 • b) Arial 

 • c) Calibri 

 • d) LiberaƟon Serif 

 • Answer: d) LiberaƟon Serif 

 3. Which opƟon is used to insert a picture into a document? 



 • a) Insert > Table 

 • b) Insert > Image 

 • c) Insert > Hyperlink 

 • d) Insert > Chart 

 • Answer: b) Insert > Image 

 4. How can you start a new page in the middle of your document? 

 • a) Insert a page number 

 • b) Insert a page break 

 • c) Insert a text box 

 • d) Insert a header 

 • Answer: b) Insert a page break 

 5. Which of these is used to create a list with bullet points in 
LibreOffice Writer? 

 • a) Numbering buƩon 

 • b) Table buƩon 

 • c) Bullet buƩon 

 • d) Hyperlink buƩon 

 • Answer: c) Bullet buƩon 

 

True or False (5) 

 1. True or False: You can change the font color of text in LibreOffice 
Writer. 

 • Answer: True 

 2. True or False: To change text alignment, you must go to the Insert 
menu. 

 • Answer: False 

 3. True or False: A page break starts a new page at the end of the 
document. 



 • Answer: False 

 4. True or False: You can only insert pictures from the internet into 
your LibreOffice Writer document. 

 • Answer: False 

 5. True or False: To create a numbered list, you use the Numbering 
buƩon. 

 • Answer: True 

 

Match the Columns (5) 

 

Column A Column B 

1. To insert a table a) Font Style buƩon 

2. To change the text color b) Insert > Table 

3. To insert a picture c) Insert > Image 

4. To align text to the center d) Center Alignment buƩon 

5. To make text bold e) Bold buƩon 

 

Answer: 

 1. b – To insert a table: **Insert > Table 

 

Short Answer QuesƟons (5) 

 1. What is the use of the Font Style feature in LibreOffice Writer? 

 2. How can you change the alignment of text in a document? 

 3. What is the purpose of a page break in LibreOffice Writer? 

 4. How do you insert a table into a document? 

 5. Name the steps to insert a picture into a LibreOffice Writer 
document. 

 



Long Answer QuesƟons (5) 

 1. Explain the process of formaƫng text in LibreOffice Writer. Discuss 
how to change the font style, size, color, and how to apply bold, italics, and 
underline to text. 

 2. Describe how you can insert and format a table in LibreOffice 
Writer. Include steps to add rows and columns, and how to adjust the table 
size. 

 3. How do you create and organize lists in LibreOffice Writer? Discuss 
how to create bulleted lists and numbered lists and how they help in organizing 
informaƟon. 

 4. Explain how you can customize the layout of a document using 
LibreOffice Writer. Describe how to set up margins, adjust paragraph spacing, 
and modify indentaƟons. 

 5. Discuss how to insert and manage images in a LibreOffice Writer 
document. Explain how to add an image, resize it, and move it within the 
document. 

 

  



CHAPTER 4 

Tables in Libre Office Writer 
 

IntroducƟon to Tables in LibreOffice Writer 
 

A table in LibreOffice Writer is a way to organize data into rows and columns, 
making it easy to present and manage informaƟon. Tables are oŌen used in 
documents to structure data, such as lists, schedules, or comparisons. In this 
lesson, we will learn how to create and modify tables in LibreOffice Writer. 
 

How to Create a Table in LibreOffice Writer 
 

To create a table in LibreOffice Writer, follow these steps: 

 1. Click on the “Table” menu: This opƟon is located on the menu bar 
at the top of the screen. 

 2. Select “Insert Table”: A dialog box will appear where you can 
specify the number of rows and columns for your table. 

 3. Specify the number of rows and columns: In the dialog box, enter 
the number of rows and columns you want for your table. 

 4. Click “OK”: The table will appear in your document with the 
specified number of rows and columns. 
 

Modifying a Table 
 

Once the table is created, you can modify it in several ways: 
 

1. InserƟng or DeleƟng Rows and Columns 

 • To Insert a Row or Column: 

 • Right-click in a cell where you want to add a row or column. 

 • From the context menu, select Insert Row Above, Insert Row 
Below, Insert Column LeŌ, or Insert Column Right. 



 • To Delete a Row or Column: 

 • Right-click on the row or column you want to delete. 

 • Choose Delete Row or Delete Column from the context menu. 
 

2. Merging and Spliƫng Cells 

 • To Merge Cells: Select the cells you want to merge, right-click, and 
choose Merge Cells. 

 • To Split Cells: Right-click on a merged cell and choose Split Cells 
from the context menu. 
 

3. AdjusƟng the Table Size 

 • Resizing the Table: You can adjust the table’s size by clicking and 
dragging the table borders. You can also adjust the size of individual rows or 
columns by placing your mouse pointer between the row/column headers and 
dragging. 
 

Formaƫng a Table 
 

Tables can also be formaƩed to make them more visually appealing. Here’s 
how: 

 1. Changing the Table Border: 

 • Right-click on the table and select Table ProperƟes. 

 • In the Borders tab, you can change the line style, thickness, and 
color of the table borders. 

 2. Shading and Coloring Cells: 

 • Select the cells or the enƟre table. 

 • Right-click and choose Table ProperƟes, then go to the Background 
tab. 

 • Here, you can choose the color you want to fill the selected cells 
with. 



 3. Aligning Text in Cells: 

 • Select the cells you want to format. 

 • Right-click and choose Table ProperƟes. 

 • Under the Text Flow tab, you can change the verƟcal and 
horizontal alignment of text inside the table cells. 
 

Using Tables for Organizing Data 
 

Tables can help you organize informaƟon more clearly. Here’s how you can use 
tables for different purposes: 

 • Lists: You can use a table to organize items in rows and columns. 

 • Comparisons: Use a table to compare different items, such as the 
features of different products. 

 • Schedules: A table is great for organizing schedules with dates, 
Ɵmes, and acƟviƟes. 
 

Example of a Table in LibreOffice Writer 
 

Name Age Grade City 

John 10 A New York 

Sarah 11 B Los Angeles 

David 12 A Chicago 
 

In this table, we have organized informaƟon about students, such as their 
names, ages, grades, and ciƟes. 

 

  



Book Exercises on Tables in LibreOffice Writer for Class 5 

 

1. Fill in the Blanks: 

 1. A table in LibreOffice Writer is organized into _______ and 
_______. 

 2. To insert a table, you need to go to the _______ menu and select 
the _______ opƟon. 

 3. In LibreOffice Writer, the _______ opƟon is used to change the 
background color of a table. 

 4. To add a row in an exisƟng table, right-click on the table and select 
the opƟon _______. 

 5. The _______ feature allows you to combine two or more cells into 
one. 

 

2. MulƟple Choice QuesƟons (MCQs): 

 1. How do you delete a column in a table in LibreOffice Writer? 

a) Right-click the column and choose Delete Column 

b) Press Delete on the keyboard 

c) Right-click the row and choose Delete Row 

d) Click the table border and press Delete 

 2. Which of the following can you do to make a table more readable? 

a) Change the font size 

b) Add a border 

c) Apply shading to cells 

d) All of the above 

 3. To merge two cells in a table, you should: 

a) Select both cells and right-click to choose Merge Cells 

b) Select both cells and press Enter 



c) Highlight the cells and select Delete Cells 

d) Select the cells and press Ctrl + M 

 4. Which of the following opƟons is used to align text in the center of 
a cell in a table? 

a) Right-align 

b) LeŌ-align 

c) Center-align 

d) JusƟfy-align 

 5. What does the Insert Table dialog box allow you to do? 

a) Add borders to a table 

b) Merge cells in a table 

c) Choose the number of rows and columns for a table 

d) Change the font of the table text 

 

3. True or False: 

 1. You can resize a table by dragging its borders. 

 2. To insert a new row, you need to click the “Table” menu and select 
“Insert Row”. 

 3. Shading and borders can be added to tables through the “Table 
ProperƟes” opƟon. 

 4. A table in LibreOffice Writer can only have rows and columns, but 
not merged cells. 

 5. The “Delete Column” opƟon will remove all the contents in a 
selected column of a table. 

 

4. Match the Columns: 

 

Column A Column B 



1. Insert a Table A. Allows you to change the table’s appearance 

2. Delete Row B. Adds a new row in the table 

3. Merge Cells C. Removes a row from the table 

4. Table ProperƟes D. Combines mulƟple cells into one 

5. Shading Cells E. Adds color to the cells 

 

5. Short Answer QuesƟons: 

 1. What is the purpose of merging cells in a table? 

 2. How do you add a new column in an exisƟng table? 

 3. What are the steps to format the text in the cells of a table? 

 4. What are the two main elements you need to specify when 
creaƟng a table in LibreOffice Writer? 

 5. How can you adjust the size of a table in LibreOffice Writer? 

 

6. Long Answer QuesƟons: 

 1. Explain the process of creaƟng a table in LibreOffice Writer. 
Include details on inserƟng rows, columns, and how to modify the size of a 
table aŌer it has been created. 

 2. Describe how to format a table in LibreOffice Writer. What are the 
steps to change the table’s background color, add borders, and align text in 
cells? 

 3. What is the difference between merging and spliƫng cells in a 
table? How and when would you use these features in a document? 

 4. How can tables improve the organizaƟon of data in a document? 
Provide examples of how tables can be used in various types of documents 
such as reports, schedules, and comparison charts. 

 5. What are some Ɵps to make a table look more aƩracƟve and 
readable? Discuss methods like adjusƟng font size, cell alignment, shading, and 
borders. 

  



CHAPTER 5 

Libre Office Impress 
 

IntroducƟon 

 

A presentaƟon is a way to communicate an idea, concept, or message to an 
audience in a visual and engaging manner. PresentaƟons are commonly used in 
schools, businesses, and public events. With LibreOffice Impress, you can 
create text-based, image-based, and audio-visual presentaƟons. Impress 
provides an easy-to-use plaƞorm for creaƟng professional-looking slideshows, 
making it a great tool for both educaƟonal and professional purposes. 

 

StarƟng LibreOffice Impress 

 

To open LibreOffice Impress, follow these simple steps: 

 1. Click on the Show ApplicaƟons buƩon on your desktop or taskbar. 

 2. Type “LibreOffice Impress” into the search bar. 

 3. Click on the LibreOffice Impress icon to open the applicaƟon. 

 

Once opened, you can start working on your presentaƟon by adding slides, 
text, images, and more. 

 

Components of LibreOffice Impress 

 

LibreOffice Impress has several components to help you create and organize 
your presentaƟon efficiently. 

 1. Title Bar: The topmost bar displays the name of the presentaƟon 
file and the applicaƟon. 



 2. Menu Bar: Located just below the Ɵtle bar, it contains various 
menus (e.g., File, Edit, View) that provide commands for working with the 
applicaƟon. 

 3. Toolbars: These are command buƩons found below the menu bar. 
They contain opƟons for performing funcƟons like adding text, images, and 
formaƫng the slides. 

 4. Slide Pane: On the leŌ side of the window, this area shows small 
previews (thumbnails) of your slides. 

 5. Workspace: The main area where you design and edit each slide. 

 6. Task Pane: On the right side, it contains tools for layout, 
transiƟons, animaƟons, and more. 

 7. Sidebar: Provides quick access to various tools and features like 
properƟes, gallery, and slide navigator. 

 8. Status Bar: Located at the boƩom of the window, it shows details 
about the current slide, such as slide number and the current view. 

 

CreaƟng a New PresentaƟon 

 

To create a new presentaƟon, follow these steps: 

 1. Click on the File menu. 

 2. Select New, then choose PresentaƟon. 

 3. A blank Ɵtle slide appears. You can add text by clicking inside the 
placeholders and typing your Ɵtle and content. 

 

Adding Slide Content 

 

To add content to your slide: 

 1. Click on the text placeholder and type your Ɵtle. 

 2. Click on the second placeholder and enter the content text. 



 3. To add more slides, follow these steps: 

 • Click the Insert menu. 

 • Select Slide from the dropdown list to add a new slide to your 
presentaƟon. 

 

Changing Slide Layouts 

 

If you want to change the layout of a slide: 

 1. Click on the Format menu and select Slide Layout. 

 2. A task pane will appear with various layouts. Choose the one that 
fits your content and click to apply it. 

 

Adding Picture from Gallery 

 

You can insert images into your slides using the Gallery: 

 1. Click on the Gallery buƩon in the sidebar. 

 2. A window will open with various images. Drag the desired image 
to the slide. 

 

AnimaƟng a Picture 

 

To make your presentaƟon more exciƟng, you can add animaƟon to objects: 

 1. Click the AnimaƟon buƩon on the sidebar. 

 2. A menu will appear with animaƟon opƟons. Select the animaƟon 
you like. 

 3. Click the Apply buƩon to add the animaƟon to your picture or 
object. 

 



Applying Slide TransiƟon 

 

Slide transiƟons make the movement between slides smooth and visually 
engaging. Here’s how to apply a transiƟon: 

 1. Click on the TransiƟon buƩon in the sidebar. 

 2. Select the transiƟon style you prefer from the available opƟons. 

 3. Click Apply to apply the transiƟon to a single slide, or Apply to All 
to apply it to the enƟre presentaƟon. 

 

Saving and Closing a PresentaƟon 

 

To save your work: 

 1. Click on the File menu. 

 2. Select Save or Save As. 

 3. Choose a locaƟon, name your file, and click Save. 

 

To close your presentaƟon: 

 1. Click on the File menu. 

 2. Select Close. 

 

Opening an ExisƟng PresentaƟon 

 

To open an exisƟng presentaƟon: 

 1. Click on the File menu. 

 2. Select Open. 

 3. Browse to the locaƟon of your file, select it, and click Open. 

 



Slide Show 

 

A presentaƟon is displayed full-screen as a Slide Show: 

 1. Click on the Slide menu and select Slide Show. 

 • OR - 

 2. Press the F5 key on your keyboard to start the slideshow. 

 

To exit the slide show, click the Esc key. 

 

ExiƟng LibreOffice Impress 

 

To exit Impress: 

 1. Click on the File menu. 

 2. Select Exit to close the applicaƟon. 

 

Conclusion 

 

LibreOffice Impress is a powerful tool for creaƟng presentaƟons. Whether 
you’re adding text, images, or animaƟons, it allows you to design visually 
appealing slideshows. By using features like transiƟons and slide layouts, you 
can create professional presentaƟons easily and efficiently. Always remember 
to save your work and pracƟce creaƟng different types of slides to become 
more comfortable with the tool. 

Here are the requested fill in the blanks, MCQs, True or False, and Match the 
Columns exercises for LibreOffice Impress: 

 

  



Exercises 

Fill in the Blanks (5) 

 1. The main area where you create and edit your slides is called the 
__________. 

 2. To start a new presentation in LibreOffice Impress, you need to 
click on the __________ menu. 

 3. A __________ is a special effect applied to a slide when 
transitioning from one slide to the next. 

 4. To add a picture to a slide, you can use the __________ button 
located on the sidebar. 

 5. The __________ shows small previews of all your slides in the left 
pane of the Impress window. 

 

Multiple Choice Questions (MCQ) (5) 

 1. Which of the following is used to create presentations in 
LibreOffice? 

 • a) LibreOffice Writer 

 • b) LibreOffice Calc 

 • c) LibreOffice Impress 

 • d) LibreOffice Draw 

Answer: c) LibreOffice Impress 

 2. What button do you click to add a new slide in LibreOffice 
Impress? 

 • a) Insert Slide 

 • b) New Slide 

 • c) Add Slide 

 • d) Slide Show 

Answer: b) New Slide 

 3.What can you apply to make your presentation more dynamic and   

             visually engaging? 



 • a) Slide Layout 

 • b) Animation 

 • c) Title Bar 

 • d) Sidebar 

Answer: b) Animation 

 4. Which of the following options helps you add transitions between 
slides? 

 • a) Transition Button 

 • b) Animation Button 

 • c) Slide Layout Button 

 • d) Gallery Button 

Answer: a) Transition Button 

 5. What is the purpose of the “Status Bar” in LibreOffice Impress? 

 • a) To show a preview of your slides 

 • b) To provide information about the slide you are working on 

 • c) To show available fonts 

 • d) To provide slide transitions 

Answer: b) To provide information about the slide you are working on 

 

True or False (5) 

 1. True or False: You can change the layout of a slide by clicking on 
the “File” menu. 

 • Answer: False 

 2. True or False: You can add images to your slides by using the 
Gallery feature in LibreOffice Impress. 

 • Answer: True 

 3. True or False: The “Slide Show” feature allows you to view the 
slides one after another in full screen. 

 • Answer: True 



 4. True or False: To save a presentation, you must click on the 
“Insert” menu. 

 • Answer: False 

 5. True or False: The Sidebar in LibreOffice Impress provides quick 
access to tools like Gallery and Navigator. 

 • Answer: True 

 

Match the Columns (5) 

 

Column A Column B 

1. Title Bar a) Displays the content of each slide in thumbnail form 

2. Slide Layout b) Shows the name of your presentation file 

3. Slide Pane c) Allows you to choose different slide layouts 

4. Animation Button d) Adds visual effects to objects in your presentation 

5. Status Bar e) Displays information about the current slide 

 

Answer: 

 1. b – Title Bar: Displays the name of your presentation file. 

 2. c – Slide Layout: Allows you to choose different slide layouts. 

 3. a – Slide Pane: Shows the content of each slide in thumbnail form. 

 4. d – Animation Button: Adds visual effects to objects in your 
presentation. 

 5. e – Status Bar: Displays information about the current slide. 

Short Questions (Answer in 1-2 sentences) 

 1. What is LibreOffice Impress used for? 

 2. Name any three components of the LibreOffice Impress window. 

 3. How can you add a new slide to your presentation? 

 4. What is a slide transition? 

 



Long Questions (Answer in 4-5 sentences) 

 1. Explain the process of adding a picture to your slide using the 
gallery. 

 2. How do you animate a picture in LibreOffice Impress? Describe 
the steps. 

 3. What is the purpose of the Slide Show feature in LibreOffice 
Impress? How can you start a slide show? 

 4. Describe the steps for changing the layout of a slide in LibreOffice 
Impress. 

 

  



 

CHAPTER 6  

IntroducƟon to LibreOffice Calc 

 

LibreOffice Calc is a free, open-source spreadsheet 
program that helps users organize, calculate, and 
analyze data. It is part of the LibreOffice suite of 
applicaƟons and works similarly to other spreadsheet 
programs like MicrosoŌ Excel but is completely free to 
use. 

 

In LibreOffice Calc, data is organized into workbooks 
(files), and each workbook contains one or more 
worksheets (pages) made up of cells. These cells are 
arranged in rows (horizontal) and columns (verƟcal). 
You can enter text, numbers, dates, and perform 
various operaƟons like calculaƟons and sorƟng within 
these cells. 

 

Some key features of LibreOffice Calc include: 

 • CreaƟng and managing worksheets. 

 • Performing calculaƟons using formulas and 
funcƟons. 



 • Formaƫng data for beƩer presentaƟon. 

 • CreaƟng charts to visualize data. 

 

 

 

 

Working with LibreOffice Calc  

 

In LibreOffice Calc, you work within a grid made up of 
rows and columns. Each cell is idenƟfied by a 
combinaƟon of its column leƩer and row number, such 
as A1 (first column, first row). 

 

Basic OperaƟons: 

 1. Entering Data: 

 • Click on a cell and type your data (text, 
number, or date). 

 • Press Enter to move down or Tab to move to 
the next cell horizontally. 

 2. EdiƟng Data: 



 • To edit a cell, click on the cell and either start 
typing directly or press F2 to modify the data already in 
the cell. 

 • You can delete the contents of a cell by 
selecƟng it and pressing the Delete key. 

 3. Formaƫng Data: 

 • You can format cells to change how the text 
looks (e.g., changing the font size, making it bold, or 
changing its color). 

 • You can also change the alignment of text 
within a cell (leŌ, center, right). 

 • Rows and columns can be resized by dragging 
the line between them, allowing you to make more 
space for your data. 

 4. Using Simple Formulas: 

 • You can perform calculaƟons using basic 
formulas. For example, to add the numbers in two cells, 
you would type =A1+B1 in another cell to get the 
result. 

 • You can also use built-in funcƟons like SUM to 
add up a range of cells, or AVERAGE to find the average 
of a group of numbers. 

 5. Saving and PrinƟng: 



 • AŌer creaƟng your workbook, you can save it 
by clicking File > Save and choosing a name for your 
file. 

 • You can print your worksheet by selecƟng File 
> Print, adjusƟng the seƫngs, and then prinƟng it. 
 

 

Book Exercises  

 

Fill in the Blanks: 

 1. To enter data into a cell in LibreOffice Calc, you need to click on the ________. 

 • Answer: cell 

 2. A formula in LibreOffice Calc always starts with the ________ symbol. 

 • Answer: = 

 3. The ________ funcƟon in LibreOffice Calc is used to add numbers in a range of cells. 

 • Answer: SUM 

 4. You can adjust the width of a column by dragging the line between two ________. 

 • Answer: columns 

 5. The ________ key is used to delete the contents of a cell. 

 • Answer: Delete 

 

2. True or False: 

 1. False: LibreOffice Calc is a free, open-source soŌware. 

 2. True: You can format cells to change the font size and color in LibreOffice Calc. 

 3. True: To enter a new formula, you type the equaƟon directly into the Formula Bar. 

 4. True: The Enter key moves the cursor to the next cell below when you are entering 
data. 

 5. True: Rows in LibreOffice Calc are idenƟfied by numbers and columns by leƩers. 

 6. False: You can resize rows and columns in LibreOffice Calc. 

 7. False: A worksheet in LibreOffice Calc is a part of a workbook. 



 8. False: You can enter text, numbers, and dates in cells in LibreOffice Calc. 

 

3. Choose the Correct Answer: 

 1. What is the starƟng symbol of a formula in LibreOffice Calc? 

Answer: c) = 

 2. Which of the following is used to create a chart in LibreOffice Calc? 

Answer: a) Insert > Chart 

 3. To resize a column in LibreOffice Calc, you need to drag the line between two 
________. 

Answer: b) Columns 

 4. Which key is used to delete data from a cell in LibreOffice Calc? 

Answer: b) Delete 

 5. Which funcƟon is used to calculate the total of a range of cells in LibreOffice Calc? 

Answer: c) SUM 

 

4. Match the Column: 

 

Column A 

 1. Formula Bar 

 2. SUM funcƟon 

 3. Cell 

 4. Rows and Columns 

 5. Formaƫng 

 

Column B 

a) Used to enter formulas and text 

b) Used to perform addiƟon on a range of cells 

c) A small box where data is entered 

d) Horizontal and verƟcal lines that organize data 

e) Changing the appearance of data in a cell (e.g., bold, color) 

 

Answers: 



1 → a) Used to enter formulas and text 

2 → b) Used to perform addiƟon on a range of cells 

3 → c) A small box where data is entered 

4 → d) Horizontal and verƟcal lines that organize data 

5 → e) Changing the appearance of data in a cell (e.g., bold, color) 

 

 

Short QuesƟons: 

 1. What is a workbook in LibreOffice Calc? 

 2. How do you enter data in a cell? 

 3. How can you edit the data in a cell? 

 4. What does the Formula Bar display in LibreOffice Calc? 

 5. Name two things you can format in a cell. 

 

Long QuesƟons: 

 1. Describe the process of entering and ediƟng data in LibreOffice Calc. 

 2. Explain how you can use simple formulas to perform calculaƟons in Calc. Provide an 
example. 

 3. How do you resize rows and columns to fit your data in LibreOffice Calc? Explain the 
steps. 

 

  



CHAPTER – 7 

MORE ON INTERNET 

 

The Internet is a global network of interconnected computers that 
communicate with each other to share informaƟon. It's like a huge library 
where you can access informaƟon, communicate with people, and share your 
own ideas. The Internet works by connecƟng millions of computers around the 
world using special cables and satellites. When you type a website's address or 
send an email, your computer sends a message to a special computer called a 
server. The server then sends the informaƟon back to your computer. 

*What Can You Do on the Internet? 

                                            

You can do many exciƟng things on the Internet, such as: 

1. Browse websites: Visit your favorite websites to play games, watch videos, or 
learn new things. 

2. Send emails: Send messages to your friends and family using email. 

3. Chat with friends: Use messaging apps or video calls to talk to your friends. 

4. Learn new things: Watch educaƟonal videos, take online courses, or read 
arƟcles on various topics. 

* Social Networking 

Social networking is a way for people to connect with each other and share 
informaƟon, ideas, and experiences using the internet. Social networking sites 
are websites or apps that allow users to create profiles, connect with friends, 
share updates, and join groups. Some popular social networking sites include 
Facebook, Instagram, TwiƩer, Youtube and whatsapp. 

 Benefits of Social Networking 

1. Connect with friends and family: Social networking sites make it easy to 
connect with friends and family who live far away. 



2. Make new friends: Social networking sites allow users to connect with 
people who share similar interests. 

3. Share experiences: Social networking sites provide a plaƞorm for users to 
share their experiences and learn from others. 

4. Stay updated: Social networking sites provide a way for users to stay updated 
on current events and news. 

 

 

Facebook is a social networking plaƞorm where users can create profiles, 
connect with friends and family, Share updates, photos, and videos, Join groups 
and communiƟes. 

Founded in 2004 by Mark Zuckerberg. 

  

 

WhatsApp is a messaging app that allows users to send text messages, make 
voice and video calls, Share photos, videos, and files 

 

 

 

TwiƩer is a microblogging plaƞorm where users can share short messages 
(tweets), Follow friends, celebriƟes, and news,  Join conversaƟons using 
hashtags 



Founded in 2006 by Jack Dorsey.  2009 by Brian Acton and Jan Koum. 

 

 

 

 

YouTube is a video-sharing plaƞorm where users can Upload, share, and view 
videos, subscribe to channels and creators, discover new content through 
recommendaƟons 

Founded in 2005 by Chad Hurley, Steve Chen, and Jawed Karim. 

 

 

*Modem (Modulator-Demodulator) is a device that connects your computer to 
the internet, Converts digital data to analog signals for transmission, allows for 
online communicaƟon and internet access 

*Internet Service Provider (ISP) is a company that provides internet access to 
customers, offers various internet plans and speeds , connects users to the 
global internet network. 

 

  



CHAPTER – 7 

 

BOOK EXERCISES  

A. Fill in the blanks. 
(internet, server, dial-up connecƟon, ISP, Modem) 

 

1. The ________ is a global network of interconnected computers. 

2. A _______is a special computer that stores websites and provides access to 
them. 

3. _______ is a way of connecƟng to the internet using a phone line. 

4. A _________ is a company that provides internet access to customers. 

5. A _________ is a device that connects your computer to the internet. 

 

B. State True or False. 

1. The Internet is a network of interconnected computers that communicate 
with each other using telephone lines only. (F) 

2. A web browser is a soŌware applicaƟon that allows users to access and view 
websites.(T) 

3. Dial-up connecƟon is the fastest way to connect to the internet. (F) 

4. ISP stands for Internet Service Provider.(T) 

5. A modem is a device that converts digital signals to analog signals.(T) 

 

 

C. Choose the correct answer. 

1. What does ISP stand for? 

A) Internet Service Provider 

B) InternaƟonal Service Provider 

C) Internet Security Provider 



D) Internet Speed Provider 

Answer: A) Internet Service Provider 

2. Which of the following is a type of internet connecƟon? 

A) Dial-up connecƟon 

B) Telephone connecƟon 

C) Television connecƟon 

D) Radio connecƟon 

Answer: A) Dial-up connecƟon 

3. What is the primary funcƟon of a web browser? 

A) To provide internet connecƟon 

B) To host websites 

C) To access and view websites 

D) To send emails 

Answer: C) To access and view websites 

4. Which device is used to connect a computer to the internet? 

A) Router 

B) Modem 

C) Server 

D) Hub 

Answer: B) Modem 

5. What is the term for a network of interconnected computers? 

A) Internet 

B) Intranet 

C) Extranet 

D) Website 

Answer: A) Internet 



Short Questions: 
 1. What is the Internet? 
 2. Name two things you can do on the Internet. 
 3. What is the purpose of a modem? 
 4. Who founded Facebook? 
 
Long Questions: 
 1. Explain how the Internet works and how computers 
communicate with each other. 
 2. Describe the benefits of social networking sites and how 
they help people connect. 
 3. What is the role of an Internet Service Provider (ISP) and 
how do they help users access the Internet? 
 4. Discuss the features and functions of some popular social 
networking platforms like Facebook, WhatsApp, and Twitter. 

 
 

 

  
 

 

  



 

CHAPTER – 8 
SMART HOMES 

  
 
You all know how much fun it is to play games, watch videos, and 
chat with friends online. But, just like how we need to be careful 
when we're playing outside or crossing the road, we also need to 
be careful when we're using computers and the internet at home. 
In this chapter, we'll learn about some simple rules to follow to 
stay safe online, how to protect our personal information, and 
what to do if we encounter any problems while using the 
computer or internet at home. 
"Imagine waking up in the morning to a house that's already 
warm and cozy, with your favorite music playing softly in the 
background. You walk into the kitchen, and the lights turn on 
automatically, illuminating the room. You ask your virtual 
assistant to brew a fresh cup of coffee, and it's ready for you in 
just a few minutes. 
Welcome to the world of Smart Homes! With the help of smart 
devices, our homes are becoming more comfortable, convenient, 
and connected. Smart homes are equipped with devices that can 
be controlled remotely, automatically, or with voice commands. 
These devices can learn our habits and preferences, and adjust 
themselves to make our lives easier. 
In this chapter, we'll explore the exciting world of smart homes 
and smart devices. We'll learn about the different types of smart 
devices, how they work, and how they can make our lives more 
convenient and enjoyable. Let's dive in and discover the future of 
living!" 

 
Benefits of a smart home: 
 
Convenience and Ease of Use 
1. Remote Control: Control your home's devices from anywhere, 
at any time, using your smartphone or tablet. 



2. Voice Control: Use voice assistants like Alexa or Google 
Assistant to control your devices with just your voice. 
3. Automated Routines: Set up customized routines to automate 
your daily tasks, such as turning on lights or adjusting the 
thermostat. 
 
Enhanced Safety and Security 
 
1. Smart Security Cameras: Monitor your home remotely with 
smart security cameras that send alerts and notifications. 
2. Smart Door Locks: Control who enters your home with smart 
door locks that can be locked and unlocked remotely. 
3. Smart Smoke Detectors: Receive alerts and notifications in case 
of a fire or smoke detection. 
  
Improved Comfort and Health 
 
1. Smart Air Purifiers: Monitor and control air quality to improve 
indoor air quality and reduce allergies. 
2. Smart Humidifiers: Control humidity levels to improve indoor 
air quality and reduce dry skin. 
3. Smart Lighting: Adjust lighting levels and colors to improve 
mood and reduce eye strain. 
  

Devices used in smart homes: 
 
1. Smart Speakers (e.g. Alexa, Google Home) 

2. Smart Thermostats (e.g. Nest, Ecobee) 
3. Smart Lighting (e.g. Philips Hue, LIFX) 
4. Smart Security Cameras (e.g. Ring, Nest Cam) 
5. Smart Door Locks (e.g. August, Schlage) 
6. Smart Plugs (e.g. TP-Link, Belkin) 
7. Smart Home Hubs (e.g. Samsung SmartThings, Wink Hub) 
8. Smart TVs and Streaming Devices (e.g. Roku, Chromecast) 
9. Smart Appliances (e.g. refrigerators, washing machines) 
10. Motion Sensors and Door/Window Sensors 
  



  
1. Smart Speakers: Control your smart home devices with voice 
commands using speakers like Amazon Alexa or Google Home. 
2. Smart Lighting: Systems like Philips Hue or LIFX allow you to 
control lighting remotely, set schedules, and adjust brightness. 
4. Smart Security Cameras: Cameras like Ring or Nest Cam 
provide live video feed, motion detection, and alerts to your 
phone. 
5. Smart Door Locks: Locks like August or Schlage can be 
controlled remotely, grant access to guests, and alert you to 
unusual activity. 
6. Smart Plugs: Devices like TP-Link or Belkin allow you to control 
appliances remotely, set schedules, and monitor energy usage. 
7. Smart Home Hubs: Hubs like Samsung SmartThings or Wink 
Hub connect and control multiple smart devices from a single 
interface. 
8. Smart TVs and Streaming Devices: Devices like Roku or 
Chromecast provide access to streaming services and can be 
controlled using voice commands. 
9. Smart Appliances: Appliances like refrigerators or washing 
machines can be controlled remotely, receive software updates, 
and provide maintenance alerts. 
10. Motion Sensors and Door/Window Sensors: Sensors detect 
movement or opening/closing of doors and windows, triggering 
alerts or automating lighting and security systems. 

 
  
A Smart TV is a television that integrates internet connectivity 
and allows users to access various online services, such 
as streaming services (e.g. Netflix, Hulu),Social 
media platforms , online gaming, music and video streaming, web 
browsing. 

 
  
A Video Doorbell is a smart doorbell that allows you to see, hear, 
and speak with visitors at your door from your smartphone or 
tablet. It typically features, a camera with live video feed, motion 



detection and alerts, two-way audio communication, night vision 
and weather resistance 
  
Smart Cameras capture video and images, motion detection and 
alerts, night vision and weather resistance 
- Remote viewing and recording 
- Alerts to smartphone or tablet 
  
Smart Smoke Detector detects smoke and fire. It also sends alerts 
to smartphone and provides voice alerts and location 

 
Smart Lighting 
Automates and controls lighting remotely, adjusting 
brightness, color, and schedule for energy efficiency, convenience, 
and enhanced home ambiance. 
 

Smart Speaker: 
A voice-controlled device that plays music, answers questions, 
controls smart home devices, and provides information on news, 
weather, and more. 
 

 

BOOK EXERCISES 
 

A. Fill in the blank.  

 

1. Smart homes use _________ technology to control and automate 
various devices. 

2. Smart speakers like Alexa and Google Home use ___________ 
recognition to understand voice commands. 

3. Smart thermostats can learn a household's temperature 
preferences and adjust the temperature _________. 



4. Smart home security systems often include ____________ 
cameras that can detect motion and send alerts. 

5. Smart home devices can be controlled remotely using a 
smartphone or tablet through a __________ connection. 

  

Answers: (1. IoT (Internet of Things), 2. Voice, 3.Automatically, 4. 
motion-sensing 5. Internet) 

 

B. Multiple-choice questions 

 
1. What is the primary function of a smart speaker? 

A) To control lighting 

B) To play music and answer questions 

C) To monitor security 

D) To adjust temperature 

Answer: B) To play music and answer questions 

  

2. Which of the following is a benefit of smart home automation? 

A) Increased energy consumption 

B) Reduced security 

C) Increased convenience 

D) Higher costs 

Answer: C) Increased convenience 

  

3. What is the purpose of a smart thermostat? 



A) To control lighting 

B) To monitor security 

C) To adjust temperature 

D) To play music 

Answer: C) To adjust temperature 

  

4. Which device is used to control and monitor smart home devices 
remotely? 

A) Smartphone 

B) Tablet 

C) Laptop 

D) All of the above 

Answer: D) All of the above 

  

5. What is the term for the network of physical devices embedded 
with sensors, software, and connectivity? 

A) IoT 

B) AI 

C) Robotics 

D) Automation 

Answer: A) IoT 

 

C. Short QuesƟons: 

 1. What is a Smart Home? 

 2. Name two benefits of having a smart home. 



 3. How can you control smart devices in your home? 

 4. What is the purpose of a Smart Smoke Detector? 

 5. What are Smart Plugs used for in a smart home? 

 

Long QuesƟons: 

 
 1. Explain the different types of smart devices used in a 
smart home. Provide examples of each type. 

 2. How do smart home devices improve safety and security? 
List at least three devices that contribute to this. 

 3. Describe the benefits of smart lighƟng and how it 
enhances the ambiance of a home. 

 4. What are the advantages of using a smart speaker like 
Amazon Alexa or Google Home in a smart home? 

 5. How do smart thermostats like Nest and Ecobee 
contribute to improving comfort in a smart home? 

****************** 
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